Module 24: UI Layer Configuration: Applets


	Lab 24-1
	Modifying a Form Applet

	Objective: To modify a form applet by removing and adding controls.
	 15-20 minutes


Instructions: 
In this lab, you will make changes to an existing applet to meet certain business requirements. You will remove the Purchased Date field appearing on the Asset Mgmt - Asset Detail Applet – Header. You will then add a status field called “XYZ Code” to the applet.

1. Determine which applet needs to be modified.

a. Start Siebel Tools and log in as SADMIN / SADMIN to the Sample database.

b. Start Siebel Call Center and log in as SADMIN / SADMIN to the Sample database. 

c. Navigate to Assets > List.

d. Inspect the form applet for the Purchased Date that will be removed from the display.


[image: image1.png]1-1KPP
Meru v New
Rsset #1% 1-1KPP
Serial #1 1-1KPP
Contacts

Employees:

Query

Product:*
Part #
Account:

site:

Standard Ppet
¥
Amsterdam Memorial (2

Dover

Manufactured

Installed: 6/30/1993 &

Registered: 711999

Asset Descrition:
Product Description: Greatest value pipet on the

Comments




e. Select Help > About View. What is the name of the Form Applet?


f. What is the name of the View?


g. Click OK to close the About View window.

2. Verify that tools.cfg parameters are set to allow string creation. To be able to create symbolic strings or string override fields, EnableToolsConstrain must be set to FALSE. This parameter determines the constrain mode. When set to TRUE, you must choose from a list of string references in order to enter values for translatable text strings, such as an Applet Title, and you cant create new symbolic strings. When FALSE, you can override the string reference using the string override property, and you can create new symbolic strings.

a. Log out and close Siebel Tools.

b. In Windows Explorer, open <root directory>/Tools/BIN/ENU/tools.cfg.
c. Verify the following parameter under the [Siebel] section:

EnableToolsConstrain   =   FALSE

d. Save changes, if necessary, and close tools.cfg.

e. Start Siebel Tools and log in as SADMIN/SADMIN to the Sample database.

3. Create a new project to hold your symbolic string. The new project stores all new or modified strings. When you want to add or work on new strings, you can use this new project.

a. In the Object Explorer, select Project.
b. Create a new record with these values:

	Property
	Value

	Name
	XYZ Strings

	Locked
	True (Checked)


Note: You can use strings from the Siebel repository (denoted by the “SBL_” prefix in the Symbolic String Name property) by selecting the strings you wish to modify and changing their Project property to the new project.

4. Expose the Symbolic String object type in the OE. Recall that the OE can display many object types. To simplify usage, you can show or hide these types as a group or individually.

a. Select View > Options from the Tools application-level menu.

b. Click the Object Explorer tab.

c. Click the check box next to the Symbolic String object. This will expose the Symbolic String object type and its child objects in the OE.

d. Click OK to return to Siebel Tools.

5. Create a new symbolic string that will be used to display the XYZ Status code. After defining the string object once, you can reference it anywhere in the application. Any change necessary to the string can be made once in Tools, and the resulting change will appear wherever referenced in the application.

a. In the OE, select Symbolic String.

b. Click anywhere in the OBLE and then enter Ctrl+N to create a new record.

c. Set the properties for this new symbolic string definition using values from the table below.

	Property
	Value

	Name 
	X_ASSET_CODE

	Current String Value
	XYZ Code

	Project 
	XYZ Strings


6. Modify the Asset Mgmt - Asset Detail Applet – Header applet. 

a. Select Applet :: Asset Mgmt - Asset Detail Applet – Header applet. To which project does the Asset Mgmt - Asset Detail Applet – Header applet belong?

b. Right-click on the applet and select Lock Object. You cannot make changes until you lock the object.

c. Right-click on the applet and select Edit Web Layout.

d. In the Controls/Columns window, make sure the Mode: field is set to 1: Edit. If not, set it now. Applet modes determine how a given applet is rendered at runtime. In this case, you want to allow users to edit records, create new records and query records in a form applet. Edit mode enables all this.

e. In the Controls/Columns window, increase the width of the Mapped column until it is sufficiently wide to read. Note that fields have a mapped value of Y or N (Yes or No). Mapped indicates whether a given control is mapped in the selected applet.

f. In the Controls/Columns window, ensure that Show unmapped controls only has a check mark. Any given applet can incorporate the use of a large number of controls. You can limit the controls visible in the Controls/Columns window to display only those controls that are unmapped in the currently selected applet.

7. Remove the Purchased control and label from the applet.

a. In the Web Layout editor, select the Purchased control.
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b. Right-click and select Delete.

c. Select the Purchased label.

d. Right-click and select Delete. Note that the Purchased text control and label you just deleted now appear in the Controls/Columns window as an unmapped control.

e. Right-click on the Web Layout Editor window tab above the window and select Close. In the dialog box that appears, click OK to save the applet.

8. Edit the Status label to show the caption XYZ Code that was created above.

a. In the OE, select Applet :: Asset Mgmt - Asset Detail Applet – Header | Control :: Status.
b. In the OBLE, change the property Caption – String Reference to X_ASSET_CODE. This will cause the Status Label to display the new XYZ Code string. It also sets the Caption to the reference’s associated string you created earlier, XYZ Code. 

9. Add a control to the form applet.

a. In the OBLE, right-click the Asset Mgmt - Asset Detail Applet – Header applet and select Edit Web Layout.
b. In the Controls/Columns window, ensure that Mode is set to 1: Edit.
c. In the Controls/Columns window, find the StatusLabel control. Drag and drop it onto the form applet where the Purchased label previously appeared. Note that the StatusLabel control is now labelled “XYZ Code”.
d. In the Controls/Columns window, find the Status text control. Drag and drop it onto the form applet where the Purchased label previously appeared. Note that the Status text control is now labelled “XYZ Code”.
10. Format the form applet.

a. Hold down the Shift key and select the Status text control. Don’t select the label.

b. Continue to hold the Shift key down and select the Part # text control. Both controls should now be selected. When selecting multiple items, any format changes you make will conform to the format of the last item selected. Ensure that the Part # text control was selected last.

c. Siebel Tools includes an application-level menu that allows you to perform a number of formatting tasks. From the application-level menu, select Format > Make Same Size > Both. This will make the Status text control the same size as of Part #.

d. Select Format > Align > Lefts. This will align the left edges of the controls so they appear in a single column.

e. To unselect all controls, click in the gray area of the applet.

f. Select the StatusLabel control. Press Shift and select the Part # label. Select Format > Align > Rights. This will align the right edges of the controls so they appear in a single column.

g. Close the layout editor. When prompted, ensure you save your changes.

11. Compile the work.

a. If necessary, navigate to Asset Mgmt - Asset Detail Applet – Header applet.
b. In the OBLE, right-click Asset Mgmt - Asset Detail Applet – Header and select Compile Selected Objects.
c. In the dialog box, ensure that the path for the Siebel repository file is set to <root directory>/Web Client\OBJECTS\ENU\siebel_sia.srf. For these labs, since you are working on the sample database, you will compile into <root directory>/ Web Client\OBJECTS\ENU\siebel_sia.srf. When compiling, Tools defaults to <root directory>/ Tools\OBJECTS\ENU\siebel_sia.srf, which is also the srf tools runs against. Therefore, to avoid overwriting the srf file used by Siebel Tools and to save the changes to the client application, you must compile to <root directory>/ Web Client\OBJECTS\ENU\siebel_sia.srf.
   Note: To confirm that you are compiling into the right srf file,  in the application-level menu of Siebel Call Center, click Help and select About SRF. Cross check that the srf file mentioned there is the one you are compiling into.
d. Check the box marked “Auto Start Web Client”.

e. Click Compile.

12. Check your work.

a. In the Siebel client, navigate to Assets > List in the Site Map.

b. Verify that the form applet looks like this.
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13. Log out of Siebel Call Center.

Solutions Lab 24-1 Modifying a Form Applet


1.e  Asset Mgmt - Asset Detail Applet – Header.

1.f  Asset Management – Assets View.

6.a  Asset Management.

	Lab 24-2
	Creating a List Applet

	Objective: To create a list applet.
	 10-15 minutes


Instructions:
In this lab, you will create an applet to display data about assets to be used by field service representatives.

1. Create a project to hold the new applets you will build. You could use an existing project for your applet, but we’ll create a new project for the new items that we create. This way, applets associated with the existing project will remain available to other developers. Since locking the project ensures that other developers cannot access it or its objects, the project then becomes available to the developer to make associations to it in other settings, such as in Wizards.

a. If necessary, double-click on the Siebel Tools shortcut on the desktop. Login as SADMIN/SADMIN connecting to Sample database.
b. Select Project in the Object Explorer. Add a new project record (right-click in the OBLE and select New Record or enter Ctrl+N) with the following values:

	Property
	Value

	Name 
	XYZ New Applets

	Locked 
	TRUE


2. Use the List Applet Wizard to create the XYZ Asset Data list applet. It is recommended that you use wizards, wherever possible. The Wizard helps you to identify all the correct properties and automatically creates the list applet and all its child object definitions. It also relates the applet to a business component. Alternatively, you create applets manually by defining all the necessary properties and child objects.

a. To start the wizard, select File > New Object.

b. In the New Object Wizards dialog box click the Applets tab.

c. Select List Applet and click OK.  

d. In the General dialog box of the list applet wizard, set the properties to the values shown in the table, below. Use dropdown lists to populate fields, when available. This prevents typographical errors. 

When specifying the Project property, only locked projects will appear as an option in the wizard. A project must be locked before it can be related to an object. 

Upgrade Behaviour determines whether a UI object can be preserved during an upgrade. In general, it is set to Preserve. 

	Property
	Value

	Project 
	XYZ New Applets

	Name 
	XYZ Asset Data List Applet

	Display Title
	Asset Data

	Business Component
	Asset Mgmt – Asset

	Upgrade Behaviour
	Preserve


e. Click Next.

f. In the next window, select the templates for Base and Edit List modes using the values in the table below. The wizard prompts you to select templates for three different modes: Base (displays fields in Read-Only mode), Edit List (allows you to edit records, create new records and query in a list applet) and Edit. Applet List (Base/Edit List) is used for the first two modes since: 1) it most closely mirrors display requirements for your application; 2) it combines both Base and Edit mode requirements. 
	Field
	Value

	Template for Base read-only mode
	Applet List (Base/Edit List)

	Template for Edit List mode
	Applet List (Base/Edit List)


g. In the bottom dialog box of the window, select the template for Edit mode:

	Field
	Value

	Template for Edit mode
	Applet List Edit (Edit/New/Query)


h. Click Next.

i. In the Web Layout – Fields dialog box of the wizard, add the fields that will be in the applet.

i. Select Asset Number in the Available Fields window.

ii. Click the right arrow to move this field to the Selected Fields window.

iii. Repeat this step to move the fields in the order listed below, from the Available Fields to the Selected Fields window. This list represents the sequence in which the fields will appear in the list applet in the user interface. 

	Sequence
	Field Name

	1
	Asset Number

	2
	Asset Category

	3
	Asset Description

	4
	Annual Usage

	5
	Asset Age

	6
	Install Date

	7
	Serial Number

	8
	Product Name

	9
	Product Part Number

	10
	Status


iv. Click Next.

v. The Web Layout – Fields dialog box allows you to add controls to the applet. By default, all controls are selected. Click Next to accept the default.

vi. In the Finish dialog box, click Finish. Siebel wizards often provide a Finish dialog box that lists your configuration settings. 

3. Preview wizard output. Upon exiting the wizard, Tools automatically starts the Web Layout Editor.

a. Right-click anywhere on the grid in the Web Layout Editor and select Preview to visualize how the new applet will look in the interface.

b. Right-click and deselect Preview to return to the Web Layout Editor’s edit mode.

4. Set up the Product Name field so that it enables the end-user to select from a list of available products.

a. In the Web Layout Editor, select the Product Name list column.

i. If the Properties window is closed, right-click and select View Properties Window.

ii. In the Properties window, set the Pick Applet property to Asset Mgmt – Internal Product Pick Applet. In a later module, you will assign a pick applet to the Product Name field. The Pick Applet property that you specify here determines the applet to be used for the dropdown display.

iii. Ensure that the Runtime property is set to TRUE (checked). When you configure this column with a pick applet in a later module, that applet will have a button used to invoke the pick applet. The Runtime property determines whether or not that button is active at runtime.

b. Select File > Save to save your changes.

c. Close the Web Layout Editor.

5. Validate the applet and compile the changes.

a. Validate the created applet.

i. In the OBLE, select Applet :: XYZ Asset Data List Applet.

ii. Right click the applet and select Validate.

iii. Click Start to begin the validation process.

iv. Review the results. If the previous lab steps were followed correctly, the dialog will display Total tests failed : 0.
v. Click Cancel to close the validation dialog.

b. Compile changes.

i. Select Tools > Compile Projects.

ii. Make sure Selected Projects is selected.

iii. Ensure that Auto-Start Web Client is not selected.

iv. In the Projects window, select XYZ New Applets.

v. Click Compile. You must specify the appropriate .srf file to compile into, as before.

c. Can you view the new customization in the application now? Why, or why not?


Solutions Lab 24-2 Creating a List Applet


5.c  No, because the applet has not been added to a view visible in the application.
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